?

Log in

No account? Create an account
Previous Entry Share Flag Next Entry
Поддержка Smarty в PDT
coderua
SmartyPDT - плагин подсветки синтаксиса шаблонизатора Smatry.
Его можно использовать в Zend Studio, Eclipse, Aptana.
Внимание! Самая новая, на данный момент, версия (0.9.0) не совместима с Aptana 3 и Zend Studio 8. 

Smartypdt

Установка плагина:

1. Качаем плагин: http://code.google.com/p/smartypdt/downloads/list
2. Открываем любимую IDE (Zend Studio, Eclipse, Aptana)
3. Пункт меню Help -> Install New Software
2. Жмем кнопку «Add».., далее жмем кнопку «Archive» и выбираем скачанный .zip-архив;
Чтобы плагин появился в списке доступных для установки, необходимо снять галочку «Group items by category»;
После этого в списке появится выбор «Smarty Feature»

Всё готово для установки.
Жмем «Next-Next-Finish».
Для того чтобы изменения вступили в силу, перезапускаем редактор.
Теперь IDE «понимает» синтаксис Smarty и программировать становиться приятнее.